
Kiuwan for Developers for Eclipse-based IDEs
This section shows you how to integrate the Kiuwan IDE Plug-In into Eclipse-based IDEs. 
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Introduction

Kiuwan IDE Plug-In

Kiuwan allows for a true shift-left approach by integrating with all the main IDEs.

Kiuwan for Developers is a  that facilitates and automates compliance plug-in for development IDEs
with  normatives,  standards and  for several languages.security quality best practices

It provides the following benefits:

Security Vulnerabilities Detection - The plug-in allows developers to detect and fix security 
vulnerabilities, such as Injection (SQL, XML, OS, etc), XSS, CSRF, etc., directly within their 
development IDEs.
Adoption of Security and Coding Standards - The plug-in helps to ensure compliance to 
standards (CWE, OWASP, CERT-Java/C/C++, SANS-Top25, WASC, PCI-DSS, NIST, MISRA, 
BIZEC, ISO/IEC 25000 and ISO/IEC 9126) by automating the work. This plug-in connects with 
Kiuwan and harnesses the power of its quality models to prevent errors and automatically 
standardize the code.
Automatic Error Prevention - The plug-in implements and monitors compliance to coding 
standards at the time the code is entered. Thus you can avoid errors and reduce the time and 
cost of debugging and testing activities.

The Kiuwan IDE Plug-in monitors and reports on the security, quality, and efficiency of your code at the 
point that it is written. This immediate feedback provides you with the opportunity to improve your code 
before it is delivered.

Supported Eclipse-based IDEs

The Kiuwan IDE Plug-In has been successfully tested in following IDEs and :minimum versions

Eclipse: Luna (4.4) 
RAD (Rational Application Developer for WebSphere): 9.5
IBM Rational Developer for i Systems: 9.5, 9.6
IBM Rational Developer for z Systems: 9.5.1

The Kiuwan Plug-In for Eclipse IDEs is available in both Analyzer and Viewer mode.



1.  

For others IDEs and versions, please contact Kiuwan Technical Support.

Requirements

The Kiuwan IDE Plug-In requires  or above (either JDK or JRE).Java 8

You may download it from  .http://www.oracle.com/technetwork/java/javase/downloads/index.html

Please visit  for further information.Installation and Network Configuration

Installation

To install Kiuwan for Developers just follow the steps below:
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Note for Eclipse 2019-12 users (or following versions)

Due to changes in the Eclipse core, a special installation procedure is needed from Eclipse 
2019-12.

Please follow these steps if your Eclipse version is equal or greater than 2019-12:

Open the "Window" > "Preferences" dialog.
Select "Install/Update" > "Available Software Sites" option.
Click on the "Add..." button. A new dialog will be shown with two text fields.
Set the "Name" field to "Eclipse Oxygen.2"
Set the "Location" field to "http://download.oracle.com/otn_software/oepe/library

"/eclipse-oxygen.2
Click the "Add" button. This will add the defined software site to your list.
Check the "Eclipse Oxygen.2" software site in the list if it is not already checked.
Follow the standard installation instructions.

Note for Linux/Unix users

If you are running Eclipse under Linux/Unix you can experience problems after 
installing the plug-in. 

That's due to some well-known problems with GTK3 use by Eclipse distributions. Please visit 
the following links for further information.

http://www.jroller.com/andyl/entry/mars_on_linux
https://askubuntu.com/questions/761604/eclipse-not-working-in-16-04 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=430736 

To solve this issue, please modify   :eclipse.ini

Add to your :eclipse.ini

--launcher.GTK_version 
2 

before the line:  

--launcher.appendVmargs 

https://www.kiuwan.com/docs/display/K5/Troubleshooting#Troubleshooting-ContactKiuwanTechnicalSupport
http://www.oracle.com/technetwork/java/javase/downloads/index.html
https://www.kiuwan.com/docs/display/K5/Installation+and+Network+Configuration
http://www.jroller.com/andyl/entry/mars_on_linux
https://askubuntu.com/questions/761604/eclipse-not-working-in-16-04
https://bugs.eclipse.org/bugs/show_bug.cgi?id=430736
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If the installation was successfully completed, Kiuwan for Developers will be up and running upon restart!

Updates

https://www.kiuwan.com/terms-of-use/
https://www.kiuwan.com/terms-of-use/
https://www.kiuwan.com/terms-of-use/


The Kiuwan IDE Plug-In checks automatically for updates on Eclipse startup and on a daily basis after 
that.

If you need to check it manually, you have two options:

Through the standard Eclipse mechanisms, or
Go to   and press the   button in Windows > Preferences > Kiuwan Check for updates Plug-in 

 section.updates

Although the central configuration is also automatically synchronized at IDE startup, it is possible to force 
its update using the  button in the  section.Force update Central configuration updates

Configuration
Connection Settings

After installation, you need to configure the Kiuwan Plug-In to connect to the Kiuwan servers.

Steps Image
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Fill in the aUser 
nd  witPassword 
h those of your 
Kiuwan Account 
and click Apply 
and Check 
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validate access.
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.Proxy Settings
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Analysis Filters

You can configure file inclusion and exclusion patterns for the analysis. Please visit   fSource Code Filters
or further help on this.

By default, only Exclude patterns are configured (containing a list of file patterns commonly containing 
not relevant sources to be analyzed).
Also, you can modify the default extensions associated with available language engines.

Visualization Options

Under  you can configure:Visualization Options

Automatic remote defects synchronization

If checked, the plug-in will automatically update the remote defects list when you select 
a project in Eclipse (mapped to a Kiuwan application) and that defects list is empty.

Mark defects as 'potential match" ...
In case the Kiuwan server reports a defect which source code text does not match the 
source within your Eclipse project, that defect is a "potential match"
If checked, the plug-in will mark those defects as "potential match"
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https://www.kiuwan.com/docs/display/K5/Source+Code+Filters
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This configuration is general to the plug-in installation, but you can configure analysis filters per-
application. 

Go to s and check Project > Properties > Kiuwan > Analysis Filter Enable project specific settings.

Map your Eclipse project to Kiuwan 
Application
After the Kiuwan IDE Plug-In is installed and the connection is configured, you are ready to map your 
Eclipse project to a Kiuwan application.

To map your Eclipse project to Kiuwan:

Go to Project > Properties
Right-click on your project and select  ...Configure > Convert to Kiuwan Project
Right-click on your project and select .Properties

The following dialog will open.



Mapping your Eclipse project to a Kiuwan Application allows executing a plug-in analysis synced to the 
Kiuwan Model defined at the application level.

This means that the plug-in analysis will be executed with the same Model (rules, configuration, etc.) 
defined for the Kiuwan application.

Please visit   for further help on Kiuwan Models.Models Manager User Guide

Also, mapping your project to a Kiuwan Application allows you to download the defect list found by 
Kiuwan servers to Eclipse, so you can work locally on fixing those defects.

Kiuwan Plug-In execution modes

The Kiuwan Plug-In can be configured to run in different :execution modes

Manual
You manually invoke the Kiuwan analysis

Automatic
Kiuwan analysis is executed automatically upon changes in the code.

By configuring the plug-in, you can decide Kiuwan will be executed and files will be analyzedwhen which  .

Manual analysis

If your Eclipse project is NOT configured to "Build Automatically", Kiuwan will only run on-demand.

In this case, to manually execute the analysis, left-click on the selected item (file, folder, project) and 
select . Kiuwan will then execute the analysis on the selected item(s).Run Kiuwan Analysis

Analysis permissions

To be able to analyze in Eclipse, your Kiuwan user must have been configured with, at least, r
 on the Kiuwan applicationead permission

https://www.kiuwan.com/docs/display/K5/Models+Manager+User+Guide


Automatic analysis

If your Eclipse project is configured to , Kiuwan will run automatically and you can Build Automatically
configure  the analysis will run and on  files.when what

The Kiuwan IDE Plug-In execution mode is configured at Window > Preferences > Kiuwan > 
Analysis Options

If your Eclipse project is configured to "  and "Build Automatically Automatic quality analysis
" is checked:

Kiuwan will analyze a file after you save the file. Only the selected file will be analyzed.

Build options - Do full builds

If your Eclipse project is configured to  and  is checked: Build Automatically Do full builds

Kiuwan will analyze the complete project when you Clean the project.

Please note that this option is only available if  is checked.Automatic quality analysis



Kiuwan IDE Plug-In Defects List

To view the analysis' defects list, go to Window > Show View > Other >  Kiuwan

Local defects list

The local defects list displays defects found during local analysis executed within your Eclipse.



Double-click on a defect to open the associated file in the Eclipse editor. The cursor will be placed on the 
affected line. 

Right-click on a defect to inspect the Rule information of a defect to better understand it. (A browser will 
open to display the Rule Information page. You may be asked for your Kiuwan credentials.)

Vulnerabilities details (Source and Sink) 

Security defects (i.e. vulnerabilities) are prefixed by a   icon. >

Clicking the  icon will open details on associated   and   of the defect.> Source Sink

Just double-click on any of them to open source file and line.

Local Analysis Configuration

The Kiuwan IDE Plug-In will execute the analysis with the rules contained into the model associated to 
the mapped Kiuwan application.

But it also allows you to  .reduce the scope of the analysis to a subset of that model

When you execute the local analysis on your Eclipse project, the number of defects can be quite large. If 
you are not going to work on all of them, you should consider reducing the analysis to let you concentrate 
on the most important subset of defects. The Kiuwan IDE Plug-In allows you to configure the local 
analysis to only report defects based on Priority, Characteristic, Language or even a subset of a file 
(based on file path substring)

This would allow you to concentrate on a specific set of rules or files, reducing the number of defects that 
appear in the list. Only those defects matching the filters will be displayed.

Max number of defects

An important point is to set a limit for the number of defects displayed in the list. 

It's set to 100 by default. You can increase such limit, but performance of your Eclipse can be 
seriously damaged. Take care not to set that limit to a high number.



You can access the Local Analysis Configuration by clicking on the   icon of the Local Defects list. 

Note: All the options unchecked are equivalent to all checked.

Configuring Defects View

Regardless of you have configured the subset of defects of K4D analysis (see above), you can further 
reduce the defects view by defining additional filtering conditions.

The most important filter is :Scope

File option will only display defects of the selected file in the Eclipse source file editor
Project option will display the defects of the entire project

Additionally, you can define filters based on Priority, Characteristic and Language.

Click the   icon of Local Defects listDefine to view filters.

Note: All the unchecked options are equivalent to all the checked ones.



Server defects list

For example, let's consider that at some predefined point in the application life cycle (for example, 
previously to commit a new release to a pre-production environment), the application is analyzed in a 
centralized environment.
This analysis finds some defects that must be fixed before deploying to next phase. So, you, as a 
developer, will be notified that you must fix some blocking defects. 
When you start working on it, you need to have full and easy access to those "server" defects. 
Why do you need to have access to server defects? Because it's very likely that your Local defect list is 
different from the Server defect list:

Your current source code could be different from the source code of the server (you or others 
might have already modified that version)
The list of defects to be fixed will be most probably a subset of all defects found during the 
server analysis (more on this topic below)

In these cases, you will need to have access to server defects.

Source of Server defects list

The server defects list displays defects of the application stored in the Kiuwan servers.

This utility allows developers to download defects found during the Kiuwan analysis of the 
application in a centralized environment.



Depending on your needs, the  of server defects could be different:source

Last baseline analysis
All the defects found during last complete application analysis (i.e. the Application 

)Baseline
Action plan

Defects included within an (you can select the plan from the app's list of Action Plan 
available action plans)

Audit Delivery
Defects that must be fixed so the  of the delivery can be successful (you can Audit
select the delivery among the list of executed deliveries)

Please, visit   documentation for a full explanation of Baseline, Delivery and Audit Kiuwan Life Cycle
concepts).

Click the   icon of the Server Defects list to access the Source of Server Defects. 

Note: All the unchecked options are equivalent to all the checked ones.

Filter server defects to download based on Priority, Characteristc, Language or File Pattern, and to 
configure the source of server defects. 

Configuring Filters
Besides to configure source and filters, you can further reduce the server defect list by defining additional 
filtering conditions.

Click the   icon of the Server Defects list to define view filters.

Note: All the unchecked options are equivalent to all the checked ones.

Max number of defects

An important point is to set a limit for the number of defects displayed in the list. 

By default, it's set to 100. You can increase such limit, but the performance of Eclipse can be 
seriously damaged. Do not to set that limit to a high number.

https://www.kiuwan.com/docs/display/K5/Kiuwan+Life+Cycle


Filter Description

Scope File = Only display defects of the selected file in the Eclipse source file editor

Project = Display the defects of the entire project

Orphan
defects

Display only those defects matching your current source code (defects with the associated local resource) or those that don't (defects without associated local 
resource), or all of them.

Muted Display a server defect could have been muted (for example, because it's a false positive or because it's a so special condition that must not be fixed).

Life 
Cycle 
Status

To Review, Reviewed, or None

When server defects are downloaded, you can filter defects based on their status. 

Review
ed 
Locally

If you work on a to-review server defect, right-clicking on the defect you can "Mark as reviewed locally" that defect (see image below).

Then, that defect will be marked as Reviewed locally

Additionally, you can define filters based on  ,  and  .Priority Characteristic  Language

Support and Troubleshooting 
If you experience problems with the Kiuwan plugin for Eclipse, you can read Kiuwan   to Troubleshooting
find a solution, or if you prefer you can collect troubleshooting information and send it to us.

https://www.kiuwan.com/docs/display/K5/Troubleshooting


Support Information

Important information for troubleshooting is scattered across several log and configuration files.

To make this process easier to you, just go to   aWindow > Preferences > Kiuwan > Support
nd press the   button.Extract support data

Choose the folder where you want to save this information, and submit to our technical 
support team the compressed file generated there. 

Visit   on how to contact us. We will address your problem Contact Kiuwan Technical Support
as soon as possible.

https://www.kiuwan.com/docs/display/K5/Troubleshooting#Troubleshooting-ContactKiuwanTechnicalSupport
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