Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

 

Info
titleK4D Configuration

After installation, you need to configure K4D to connect to Kiuwan servers.

K4D connection settings is configured at Window -> Preferences -> Kiuwan - Connection Settings



Fill in you User and Password of your Kiuwan Account and click Check Credentials to validate access.

In case you are using a proxy, please configure Proxy Settings.

 

Mapping your Eclipse project to Kiuwan Application

After K4D is installed and connection is configured, you are ready to map your Eclipse project to a Kiuwan application.

To map your Eclipse project to Kiuwan, you can do it in several ways:

  1. Project->Properties
  2. Right-click on your project and select Configure->Convert to Kiuwan Project...
  3. Right-click on your project and select Properties.

Next dialog will be open.

 

 

To map your Eclipse project to a Kiuwan Application allows to execute K4D analysis synced to the Kiuwan Model defined at application level.

This means that K4D analysis will be executed with the same Model (rules, configuration, etc.) defined for for the Kiuwan application.

Please visit Models Manager User Guide for further help on Kiuwan Models.

 

Also,  mapping your project to a Kiuwan Application allows to download defect list found by Kiuwan servers to you Eclipse, so you can work locally on fixing those defects.

 

K4D execution modes

 

Info
titleExecution modes

K4D can be configure to run in different execution modes:

  • Manual
    • You manually invoke the Kiuwan analysys
  • Automatic
    • Kiuwan analysis is executed automatically upon changes in the code.

 

By configuring K4D, you can decide when Kiuwan will be executed and what files will be analyzed.

...

Info
titleBuild options - Do full builds

If your Eclipse project is configured to "Build Automatically and "Do full builds" is checked, 

Kiuwan will analyze the complete project when you Clean the project.

Please note that this option is only available if "Automatic quality analysis" is checked.

 

 

K4D Defects List

 

To view the analysis' defects list

...

, go to Window -> Show View -> Other

...

-

...

Kiuwan

...

 

 

Image Added

 

Local defects list

Local defects list displays defects found during local analysis executed within your Eclipse by K4D.

Info
titleLocal defects list

Local defects list displays defects found during local analysis executed within your Eclipse by K4D.

 

Image Added

 

Server defects list

Image Added

Updates

Kiuwan for Developers checks automatically for updates on Eclipse startup and on a daily basis after that.

...

See contact Kiuwan Technical Support on how to contact us. We will address your problem as soon as possible.

 

 

 

 

 

================================================================

Kiuwan for Developers for Microsoft Visual Studio

 

Kiuwan for Developers (K4D) for MS Visual Studio is a plug-in for Visual Studio that facilitates and automates compliance with security normatives, quality standards and best practices for several languages.

Kiuwan for Developers monitors and reports on security and quality issues of your code at the point that it is written. This immediate feedback provides you with the opportunity to fix/improve your code before it is delivered.

This plugin connects with Kiuwan and harness the power of its security and quality models to prevent vulnerabilities and errors.

 

Installation

First, you need to configure the Kiuwan Gallery to download K4D for VS from Kiuwan.

Go to Tools -> Options

VS_01.PNG

 

 

Open Envrinment -> Extension and Updates and Add a new one with URL: https://www.kiuwan.com/pub/vsgallery/atom.xml 

 

VS_02.PNG

 

After Apply and OK, got to Tools->Extensions and Updates..

VS_03.PNG

  

Select Online -> Kiuwan Gallery

VS_04.PNG

 

And click Download. Next, you need to close VS to K4D to be installed.

VS_06.PNG

 

Click Modify and K4D is downloaded and installed.

VS_08.PNG

 

 

 

Configuration

After installation, you need to configure K4D to connect to Kiuwan. Please, remember that you need to have a valid Kiuwan Account.

Go to Tools -> Options and select Kiuwan for Visual Studio -> Connection properties