Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  1. Open Eclipse and, in the main menu, click on Help >> Install New Software...
  2. Select the Add... option and type the following values:
    1. Name: Kiuwan
    2. Location: https://www.kiuwan.com/pub/updatesite
  3. Pressing Ok will save this new update site and Eclipse will query our server to retrieve available features and plugins
  4. The Kiuwan for Developers feature will appear in the list below, check it and click on Next >
  5. Read and accept our Terms of Use
  6. Accept the certificate used to sign our product
  7. When the installation finishes and Eclipse asks to restart the IDE, please do so

 

 

Image Modified

 

If installation successfully completes, Kiuwan for Developers will be up and running upon restart!

...

  1. Configure your Kiuwan account and check that there are no problems with your connection and permissions.
  2. Add the Kiuwan Nature to the projects you want to analyze.
  3. Learn how and when Kiuwan for Developers analyze your sources.
  4. Learn about the views that display your analyses results.

 

Configuration

 

Info
titleK4D Configuration

After installation, you need to configure K4D to connect to Kiuwan servers.

K4D connection settings is configured at Window -> Preferences -> Kiuwan - Connection Settings


Image Added


Fill in you User and Password of your Kiuwan Account and click Check Credentials to validate access.

In case you are using a proxy, please configure Proxy Settings.

 

 

K4D execution modes

 

Info
titleExecution modes

K4D can be configure to run in different execution modes:

  • Manual
    • You manually invoke the Kiuwan analysys
  • Automatic
    • Kiuwan analysis is executed automatically upon changes in the code.

 

By configuring K4D, you can decide when Kiuwan will be executed and what files will be analyzed.

 


Manual analysis

Info

If your Eclipse project is NOT configured to "Build Automatically", Kiuwan will only run on-demand.

...

Info

In this case, to manully execute the analysis, left-click on the selected item (file, folder, project) and select "Run Kiuwan Analysis".

Kiuwan will then execute the analysis on the selected item(s).

 

 

Automatic analysis

 

Info

If your Eclipse project is configured to "Build Automatically", Kiuwan will run automatically and you can configure when the analysis will run and on what files.

 

K4D execution mode is configured at Window -> Preferences -> Kiuwan - Analysis Options

...

See contact Kiuwan Technical Support on how to contact us. We will address your problem as soon as possible.

 

 

 

 

 

================================================================

Kiuwan for Developers for Microsoft Visual Studio

 

Kiuwan for Developers (K4D) for MS Visual Studio is a plug-in for Visual Studio that facilitates and automates compliance with security normatives, quality standards and best practices for several languages.

Kiuwan for Developers monitors and reports on security and quality issues of your code at the point that it is written. This immediate feedback provides you with the opportunity to fix/improve your code before it is delivered.

This plugin connects with Kiuwan and harness the power of its security and quality models to prevent vulnerabilities and errors.

 

Installation

First, you need to configure the Kiuwan Gallery to download K4D for VS from Kiuwan.

Go to Tools -> Options

VS_01.PNG

 

 

Open Envrinment -> Extension and Updates and Add a new one with URL: https://www.kiuwan.com/pub/vsgallery/atom.xml 

 

VS_02.PNG

 

After Apply and OK, got to Tools->Extensions and Updates..

VS_03.PNG

  

Select Online -> Kiuwan Gallery

VS_04.PNG

 

And click Download. Next, you need to close VS to K4D to be installed.

VS_06.PNG

 

Click Modify and K4D is downloaded and installed.

VS_08.PNG

 

 

 

Configuration

After installation, you need to configure K4D to connect to Kiuwan. Please, remember that you need to have a valid Kiuwan Account.

Go to Tools -> Options and select Kiuwan for Visual Studio -> Connection properties