Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Kiuwan for Developers monitors and reports on the quality and efficiency of your code at the point that it is written. This immediate feedback provides you with the opportunity to improve your code before it is delivered.

...

Supported IDEs and Requeriments

 

Info
titleSupported IDEs

Kiuwan for Developers has been succesfully tested in following IDEs and minimum versions:

  • Eclipse : Kepler (4.2) 
  • RAD (Rational Application Developer for WebSphere) : 9.5

For others IDEs and versions, please contact Kiuwan Technical Support

Info
titleJava 8 required

Kiuwan for Developers (K4D) requires Java 8 or above —either JDK or JRE— is required.

You may download it from http://www.oracle.com/technetwork/java/javase/downloads/index.html.

Please visit Java 8 and JAVA_HOME for further info

Info
titleNote for Linux/Uxis users

If your are running Eclipse under Linux/Unix you can experience problems after install K4D

That's due to some well-known problems with GTK3 use by Eclipse distributions. Please visit next links for furhter info.

To solve this issue, please modifiy eclipse.ini :

Add to your eclipse.ini:

--launcher.GTK_version 

before the line:  

--launcher.appendVmargs 

 

Installation

 

To install Kiuwan for Developers just follow the steps below:

...