Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

 

This section will show you how to integrate the Kiuwan Visual Studio Extension (Kiuwan IDE Plug-In) into Microsoft Visual Studio. 

Info
The Kiuwan Visual Studio Extension is available only in Viewer Mode and supported for Visual Studio 2015 and 2017.


Contents

Table of Contents

Excerpt Include
Kiuwan for Developers
Kiuwan for Developers
nopaneltrue

Installation

First, configure the Kiuwan Gallery to download the Kiuwan VS Extension from Kiuwan. 

  1. In Visual Studio, go to Tools > Options 



  2. Open Environment >> Extension and Updates and Add a new one with URL: https://www.kiuwan.com/pub/vsgallery/atom.xml



  3. After Apply and OK, go to Tools > Extensions and Updates..



  4. Select Online > Kiuwan Gallery  



  5. Click Download. Then, you need to close Visual Studio to finish the installation. 



  6. Click Modify and the Kiuwan Extension is downloaded and installed.

 

Configuration

Connect to Kiuwan

After installation, you need to configure the Kiuwan Extension to connect to Kiuwan. Please, remember that you need to have a valid Kiuwan Account.

InstructionsImage

Go to Tools > Options and select Kiuwan for Visual Studio > Connection properties

Info
titleProxy settings
If you are using a proxy, please configure Proxy Settings.


Click Check credentials before applying the changes with OK.

Map your VS Project to Kiuwan Application

After the installation, you are ready to map your VS project to a Kiuwan application.

Info
This action will allow synchronizing defects and vulnerabilities found by Kiuwan in your source code, getting them ready for fixing.


To map your VS project to Kiuwan, right-click on your project and select Kiuwan Project Properties.

A dialog will open with a combination of available applications where you can select the application that matches your project in the Kiuwan account.

Kiuwan Defects List

Once mapped, you can open the Kiuwan Defects List by selecting go to View > Other Windows > Kiuwan Defects Window to open the Kiuwan Defects List.

You can also open the Kiuwan Defects List by clicking on the Kiuwan icon  in the Solution Explorer toolbar  toolbar

  


The Kiuwan Defect List window will appear docked to your VS layout. Double-clicking on a defect will open the file and highlight the line of the defect.


In case the selected defect is a injection vulnerability, you can see the Propagation Path at the Properties tab
Right-click on a defect for two options: 

  1. Mark the defect as reviewed
  2. Open a browser window to see information about the rule (please use the same credentials as those configured in Connection Properties).




Refreshing Defects List

To be sure you are working on the latest list of defects found by Kiuwan, you need to manually refresh the defect list.Click the  icon to update the Kiuwan Defects List to the latest content of the Kiuwan servers.

Configuring the Contents of  Defects List

Click the  icon to configure the Contents of Kiuwan Defects List.



Configuring the Filters of  Defects List

Click the icon to configure Filters in the Kiuwan Defect List.

Support and Troubleshooting 

If you experience problems with the Kiuwan extension for Visual Studio, you can read the Kiuwan Documentation to find a solution, or if you prefer you can collect troubleshooting information and send it to us. Visit Contact Kiuwan Technical Support to learn how to contact us. We will address your problem as soon as possible.